msgbartop
All about Google Chrome & Google Chrome OS
msgbarbottom

13 Nov 11 How to Install "Incompatible" Firefox Add-Ons After Upgrading to the New Firefox


WonderHowTo

To the displeasure of many loyal Firefox users, Mozilla has been deploying what seems like a new marketing strategy to “catch up” to Google Chrome. I have no idea if this is because the version number is higher than theirs, but it is downright annoying. It’s not all complaints, though. Firefox has done an amazing job at completely revamping its source code and redesigning all of its engines, making it a more than worthy competitor to Chrome. However, we are displeased with Firefox because everytime they release a new version (Firefox 4, 5, 6, 7, etc.), all of the add-ons subsequently break.

Add-ons for Firefox, such as a theme, are tossed into a .jar file, which contains all of the code for the plugin. When a plugin is developed, you must add the version compatibility to a text file. If the version of Firefox is not within the range of the compatibility specified in the add-on, the add-on will cease to work, and will automatically disable itself.

You all know what this means! This Null Byte is going to present a couple of ways to get around this limitation. This will relieve your stress with your browser, once you can use Google Sharing again and get back to playing Skyrim, everything will be dandy!

Requirements

  • Windows or Linux
  • Firefox
  • A plugin to mess with

Step 1 Navigate to the Add-on Directory

We need to get to the directory our add-ons are in so we can search for an incompatible one to hack.

  1. If you use Windows, navigate here:
        C:Documents and SettingsWindows login/user nameApplication DataMozillaPlugins
  2. If you use Linux, navigate here:
        /home/USERNAME/.mozilla/firefox/PROFILE-GOES-HERE/extensions
       

Step 2 Pick an Add-on to Hack

Text in bold are Linux terminal commands.

Pick an addon listed in that directory. If it is an .xpi file, you will need to extract it, then rewrap it after we are done by renaming it to what it was before after recompression.

Here’s what I did for the googlesharing addon:

  1. Open up the isnstall.rdf file.
        nano install.rdf
  2. Scroll down to find this block of text.
  3. Change the maxVersion to something higher than your browser version, and that’s it!

You can also install Add-on compatibility reporter, which disables version checks and installs add-ons anyway.

Follow me on Twitter and join IRC!

Image by djog

Via How to Install “Incompatible” Firefox Add-Ons After Upgrading to the New Firefox on null-byte.wonderhowto.com.

Read more posts on WonderHowTo »

Article source: http://www.businessinsider.com/how-to-install-incompatible-firefox-add-ons-after-upgrading-to-the-new-firefox-2011-11

Tags: ,